[Fixed in 3.0.1] Game crashing when activating ultimate gems

Game crashes alot when activating characters ultimate gems

1 Like

Heard another PS5 player (JoshRyan2406) mention this whenever he used Mercenary’s greed gems. Crashed his game. I recommended he uninstall, rebuild database, and reinstall.

2 Likes

I think its only with gems that need to be activated i.e necro, merc ect. Its crashing about once per 10 activations or so

If anyone could share a video, that would be excellent - haven’t been able to reproduce this one so far

1 Like

Same problem here PS 5 crashes after activation a special gem. I will re-instal as suggested.

1 Like

It seems to work like a charm. Thx for the solution. Btw a great feature when it does crash, it started exactly were I left of.
have great day.

My game crashes all the time. Twice during the same dragon fight when clolicking on the treasure gems.
Also a handful of times during coop dingeons.

I’ll try to reunstall the gams and see if that works

1 Like

@Jeto https://youtube.com/clip/UgkxetrT0-52F0SSmP_Puzl0v32wkMuk2Lap?si=i8cgMht8gDmxdrIb

Sorry its a bit long i had to stream in order to get a clip and it was acting weird…crash is at very end of clip

For everyone this is affecting, do me a favor. Try going into the settings and then display and then post what graphics mode you’re using. Also if you’re not using Performance mode, try switching to it, as its much easier on the playstation IMO and you really won’t notice a drop in visual quality if you do. See if that fixes the issue?

@KenpoKid69 i have tested both settings it dont make a difference and after crashing on performance… settings auto put it back to quality

1 Like

Yeah, I had this happen tonight on performance mode with a Necromancer on the PS4. Haven’t had it happen yet (at least not that I’m aware of) when doing auto-play though, oddly enough.

1 Like

Yea it happens on auto for me too…At least its not frequent for you like it is me. It is very frusterating crashing mulitiple times during kingdom defense…and making just playing in general tedious with lots of reconnects due to crashing been trying to avoid using ultimates. :cold_sweat::rage:

Hey all,

A fix for this will be in the hot fix we’re currently testing.
We hope to have the hotfix rolled out in the next week or so.

Thank you so much for your patience while we’ve been working on the fix and now the testing.

3 Likes

@Jeto and @Kafka this issue has not been fixed i am still crashing…i have noticed it happens less when i activate them slowly but if i hurry and activate 1 after another quickly it crashes much more often

That would be because the hotfix has yet to release

1 Like

I recommend turning on autoplay for the time being for activating ultimate gems (and then turn back off) till the patch drops, as it won’t crash your game like it will if you activate them manually.

1 Like

Ahh ok thought it was already live sorry about that

Yes kenpo i usually auto everything that lets me… Not k.d and p.v.p which is where i crash most

1 Like

What if you use spells to trigger them like Icestorm or Harpoon Shot, that would also prevent the crashing.

Harpoon Shot is a great spell for PVP. Icestorm is a great spell for KD.