[Investigating] Search behaves erratically for equipment

One Plus 7t, latest version of Android

When I do a search in my equipment for “gold” I get a bunch of gear coming up, including matches in flavor text, and things I can’t figure out how they match at all (edit: they all have rich), but my Guard’s Belt doesn’t show up.

I’ve spoken to other people in my folks and they have one of several Guard’s Belt show up, but not all of them, or none of them, depending on the person.

Additionally, not sure if it’s a bug or not, but partial strings won’t match, for example, searching for “pact” brings up zero results.

I’m thrilled we’ve got a search now, but it’d be nice if it was reliable.

1 Like

I get results if I search for “pact” or “ward” etc, but I was having this exact same conversation with a kingdom member a few days ago and they don’t get any matches if they search for “pact” or “ward” etc even though they have items with those attributes.

I have seen that too. You seem to have solved your issue with that but for example if I search “light” I get a green broadsword show up with strong and life as the attributes. Why? EDIT: It’s now pointed out below. (Even though I checked the flavour text twice I missed it)

I think it’s because in the description (on the tab after set bonus) it uses the word “slighty”

With a slightly heavier blade, broadswords can hit surprisingly hard.
Pattern match finds “light” in “slightly”, so working as intended
(but I think it would be better if the flavour text was not part of the search!)

I tested this and Guard belt does show up for me (when Show Equipped is set to on)
And partial searches do work (e.g. pact)

Make sure the “Show Equipped” toggle is set to On

Otherwise all gear that is loaded on a hero will not show up (Basically you would be searching your pile of unassigned gear only)

I only have one Guard’s Belt, and it isn’t equipped on anyone, still doesn’t show in the searches.

Hmmm… OK
I’m using android and I can see it but I can’t imagine the search function is different on different platforms (thought that could just be a lack of imagination on my part)

I’ve re-tested and only the Yellow Guard Belt seems to show up when I search gold
So I can’t explain it

“Haste” and “haste” does not return any results either.

It looks like flavor text on Attributes is searchable, but not for the item itself.
“casting” will find results for all items with a pact attribute, but not an Elven Charm that has “casting” in the item text itself.

1 Like

search for gold returns guard belt:

but i have 3 guard belts:

1 Like

The purple one has “Rich”?

yep, but all of them also has ‘gold’ in the spell description text.

looks like text search looks at:

  • Name of item
  • Traits (like Rich/*Strike/etc)
  • Flavor text

but not:

  • The ability/spell effect of an item/spell

Seems like an oversight. Perhaps swapping out the flavor text with the spell/ability would be a good fix.

1 Like

Hey all,

We are currently working on a fix for the search function in the Gear menu, as you should be able to search almost anything from an item. So name, flavour text, gear set, description etc.

Plans for the fix to be released in the 1.4 update.

1 Like

Most of us don’t want to search the flavor text though… It being searchable means we get items added to our searches that include, for example, ice in the flavor text, when we really just wanted all gear with ‘icestrike’. So please don’t have flavor text be searchable!


I agree, searching the flavor text should be at best an option, as it is functionally unnecessary


I second (or third?) the request that flavor text not be searchable by default. I want to get hits for game relevant information, the flavor text is nice, but not in a search result. It just clutters up the results with things that are effectively irrelevant to what I’m guessing 99% of people will use the search for.


I’ll fourth that :wink: I’m trying to achieve something when I use the search function. Giving me flavour text results isn’t going to help me do that.

1 Like

I passed this on to the team as well!