Public party problem

I am trying to join a public party, but it says i can’t…any suggestions as to why?

An easy way to fix that on PSN is to stay in the game, go to settings, go to network, and do a test internet connection. This will momentarily boot you to the title screen when its finished, but when you log back on to the game, it acts as kind of like a daily reset and you’ll be able to join a public party.

Tried it, but its not working.

You could try resetting your router maybe? Unplug for 10 seconds and then plug back in. Shouldn’t hurt anything and is good to do from time to time.

Also if you change the host it might work. Like if I can’t join player B’s game, the solution is to get a third player, player C to host the game and we join that one. After they leave, the party will remain stable.

Tried that already…should i submit a bug report? Everyone in my kingdom (Insomnia) srrms to be having the same issue.

Might as well I guess. I don’t think the devs will be able to do much about it though, but I suppose it wouldn’t hurt.

Closing this thread as I can see you have created a bug thread