[Reported] Dwarves boots effect can be prevented by spells that destroy gems

As title said. It happen in every battle after I updated to 2.2, regardless of console or smartphone I use.

Hi, sorry I missed adding this to the patch notes, I will add it now.

There was a bug with the Dwarven boots where they would trigger for every gem matched above 5.

The intended behaviour is that it should only trigger once per turn when 5 or more Gems are matched.

This was corrected in the 2.2 update.

I understand it’s buggy before and need to be fixed, but seems you made another mess.
It only trigger once per COMBAT, not per TURN in version 2.2.

I guess the game failed to reset the flag when a new turn begins as intended.

Hey @Hagane

Could you grab a video, if possible, of this not activating for a second time on another turn after making 5 or more matches?

Currently able to reproduce what you are experiencing.
I also have the boots on my personal account and found every turn with 5 or more individual matches I received back some armor.

Here are some screenshots from one of my battles:

Then later the same battle

422 is 3% of my starting armor.

I’ll update my test result… This bug don’t trigger every time, but quite often.
I tried 4 times in a single combat and it failed to trigger twice. Of course I do enough match every turn.
Btw I run under timer mode.

Because the screenshots can’t show any actions or other possible variables - also hard to see what matches were made, could you grab a video/screen recording and submit it in a ticket to me, so I can investigate what you are experiencing further?

Having tested some more myself I still am unable to reproduce the inconsistency you are seeing.

Sorry, quite hard to do that myself right now (I run this on iOS while stay outdoor). Maybe later.

1 Like

After dozens of test, now I can almost figure out what caused it.
I ALWAYS face this bug when I destroyed gems via skills in current turn. If I don’t cast spells that destroy stuff, it triggers normally.
I don’t know the bug affects timer only or both, since I never use AP mode.

Hey again!

We had tested this too and got the buff multiple times in a battle - whenever you can send through a video as a ticket, I’ll jump right onto it!

Yes i think I should rename my post. It can trigger multiple times in a combat, and the bug ONLY happen in a turn that you cast a destroy spell. So I guess the flag of boots is prevented by gem destroy?

Will make video when I’m off.

UPDATE: I sent my video to you via zendesk (No.129459). Same as the one I reported in this post, 4 turns and it failed to trigger 2 times.


Any update about this?

Been reported to the team, but no info on fix - will update the thread once I have more!