[REPORTED] Troll Stench ability prevents Resistance from raising above 0 in subsequent turns

Platform, device and operation system
Android, Samsung Galaxy S10

What were you expecting to happen, and what actually happened

  • Enter fight with a Troll. Troll casts Troll Stench ability. Resistance drops to 0.
  • Player gains Resistance via equipment, ability or dungeon boon in following turn(s), including against subsequent enemies - example, Savior Legs or +armor and +resistance Dungeon boon were both tested.

Expected Result: Resistance raises as normal.
Actual Result: Resistance remains at 0.

How often does this happen? When did it begin happening?
Verified in Dragonrest Temple dungeon on 17-08-2021. Troll was not the first enemy, in case it helps with reproducing.

Steps to make it happen again
See Expected & Actual results above.

Hey @Norinth

I have tried to reproduce this myself repeatedly, and consistently saw Resistance gain in both instances.
Also in Dragonrest and with Savior Pants equipped.

Is there any steps you are taking that may differ to what I have done? Or are you able to share a video of this occurring instead?

Jeto - Support Human :woman_mage:t2:

Hi @Jeto

Reproduced again.
Note that I am wearing Savior Pants (as well as two Runic Rings, given known bugs associated with them in case of interaction / causing this behavior, which you can see in my Utimate meter before and after) and I do see the “10” popup related to Resistance gain from Savior Pants after casting Dark Ice, my right-most spell. This applied to all subsequent casts as well.
However, resistance stays at 0.

If I had to guess from your screenshots, it’s the 0 that would be the not-reproduced step (and / or the Runic Rings).
If I had to guess a possible code reason without domain knowledge, it could be that the calculation of Troll Stench’s secondary effect uses a different function from regular magic damage to resistance, setting it as a negative integer if it exceeds current resistance - until the player overcomes the difference into a positive value. Or the tooltip is missing something :smiley:

Attaching before and after screenshots.

Hope it helps!

Thanks for this extra information.

I had also tried with my Resistance down to zero as well, and it went back up. But I’ll retry with double Runic Rings.

[edit] I had one Runic ring equipped

Jeto - Support Human :woman_mage:t2:

1 Like


I did it, repro successful.
Worked out what I was doing differently. Messing around with the resistance prior to the AI casting was giving a different result.

Was able to repeat this a few times, only occurring when the Troll stench took my resistance to 0. If I had any resistance, it was replenished when casting.

Also occurs when Hero didn’t have Ruin Rings equipped.

Jeto - Support Human :woman_mage:t2:

1 Like

Next time this happens, take a screenshot of your stats. I bet your resistance is going negative due to the troll stench. That has happened to me in .36