[Resolved?] Unable to enter kingdom

I’ve been getting errors now for over an hour when trying to enter our kingdom. Tried both steam and android. Two other members are getting errors too.

Always a RE error the rest changes every time

Throne of Odin


Same here: Throne of Odin

I hope it is solved before the KD timer runs out. Not that I care much right now, though.

1 Like

Yup, seems broken for everyone in the Kingdom, just got this

I was able to do a KD attempt earlier today and it went just fine though.

BERKIEL_ELOV Throne of Odin

Edit: another one:

Throne of Odin

Same error. I checked for any Android updates, but did not see any.

Same here. Throne of Odin

The Kingdom is unstuck, apparently it started working again 2min before refresh according to a member, I only tried after the refresh so I thought that’s what fixed it but apparently not, no idea what happened but anyway it’s all good!

I still can’t get in. Same error over and over.

1 Like

yeah I saw you replied so I went ahead and tried again and sure enough it’s stuck again, that’s so weird.

1 Like

This should be fixed now, can you please let us know if you’re still having issues?


I am able to enter the kingdom. Thanks.

back in, thanks. 20 characters.

1 Like