[Reported] Current adventure

Hi jeto
Sorry to bother you again but my adventure is stuck since yesterday and can’t replay it.
I’m trying to upload a screenshot but i can’t

1 Like

Hey! This was reported to the team yesterday and we are currently investigating. No screenshots or videos necessary, I already have a couple.

1 Like

My adventure is glitched its not showing anything and it locks my game up plz fix asap!

PQ3 really starting to feel like GoW all over again, clearly just as in GoW, there is no testing…

Maybe i should get out now while i can, GoW already hardly seeing me now days due to the constant issues, really dont feel like doing it all over again in PQ3.

My adventure buggered too and am once again losing out just as i did on dawn circuit, the measly comoensation doesnt make up for it.

Created a known issues article:

Should I not get to jump back into this thread before updating the article.

Same issue. Can’t replay this one and was planning on grinding it. Really need the epic scrolls.

I finished the Adventure without any problems, when I tried to play it again I was able to select the difficulty but then the screen locked, I’m just reporting it because it looks a little different from what I’ve seen here.

This issue can occur at any point in the Adventure, unfortunately, have had reports of it happening in both the first playthrough (which happened to my personal account) or after having completed it a number of times.

But the team is aware as mentioned, and currently no further information is required for us to investigate.

Come here just to say: It’s ok now :thinking:

Should note - some players may have seen this resolve with a fix I mentioned in the other threads. Which I think is coincidental.

We have not released a fix for this specific Adventure issue. When I have more information I will post it here or in a new bug issue thread.

Wil this happen in the next adventure as well? There’s mythic relics up for grabs and I don’t want to miss them.

In any case, the problem seems to have gotten worse, yesterday I was able to do the battles with the energy supplied, today I’ve tried to log in 3 times and I always have a blocked screen

A problem you dont fix stays a problem, thats normal.
A Dev that needs long to fix critical bugs is a slow dev.
That is ok, not nice but ok.
A Dev that does not comunicate and warn its community to not spent any real money on such broken parts of the game is a bad dev.
And thats not ok
Spent second time 150 crowns now for nothing on an adventure and there isnt even a warning here in forum that the game breaks if you do it. There should be one ingame!
Greed is a sin!

But ok, thats what we are used from you and your team Jeto, and you changing absolute nothing regarding that style of working with a com is why so few ppl complain, most are just finally frustrated and dont bet a cent on you an your team anymore. They are happy if at least the core things work.
And now you can ban me again. or delete that post again.

If the lastest adventure isn’t fixed in time for me to collect the two khazdhuil relic’s then i expect them in my mail. I’ve waited a long time for this adventure to come around so i can upgrade my helm. The grind on this game is already painfully slow without these game breaking bugs. If i miss out on them two mythic relic’s then you lose a long time player who does actually spend money on your game. Btw are you for real with the price of them class skins :joy:. Maybe if you sold them separately you might actually sell some.

1 Like

I’ve been waiting a long time for those relics as well!

The Adventure is broken for me too on PS5. I had intentionally saved some gems for purchasing the relic but all I’m left with is a background image of the Adventure map with no option to back out of it. There are no icons on screen and I have to manually close the game from the PS5 dashboard.

Aren’t things like this tested before being rolled out?

Yes 2nd adventure in a row that is messed up. It’s always when you roll out a new season. Last time you messed up that i couldn’t play the game for 2 days. I’m getting very frustrated with the constant mess ups with the game. Maybe its time i gave my money to somebody who can create a game that works. Cheers hottrixx

Looking forward to those relics for my cleats and i couldn’t even start it the adventure off… not happy!

I don’t understand the technical problems and as far as I know the new features introduced may even be trying to respond to old problems, I want to believe that the problems are receiving the full attention of those responsible.

What I know is that many players are starting to feel tired of these problems and that for almost everyone, developing their equipment involves a lot of work and dedication. Even those who don’t spend a penny help keep the game healthy and I think what’s missing is direct action in the game to somehow compensate the community. Just as you use the mail to announce the new session starting or any other event, I think you could give some kind of justification directly in the game.

1 Like

Khazdhuli Expedition adventure appears to be broken for me as well.

When it unlocked yesterday, the adventure allowed me to select a difficulty level and then showed me a featureless map. At this point, the game became unresponsive. When I attempt to access the adventure now, I am shown the same featureless map and the game becomes unresponsive again.

I have been able to replicate this on both Steam and the iOS app.

A few days prior, the game was also unresponsive (across multiple platforms) following the release of the new seasonal update arrived (black background upon login, unable to access any features, text missing, game frozen).

Do we have a sense of what is causing these significant issues or an estimated time for a patch to address them?