[Resolved?] Help....there's a glitch in my Matrix. :/

Okay this is a weird one @Jeto on my PS5.

My home screen in the Tavern has gone a bit pear shaped and has made the game pretty unplayable. Everything has seized up. It becomes virtually unresponsive if I try to access settings.

I have uninstalled and reinstalled the game, deleted all data, cleared the cache etc. to no avail so it must be server side? Any help would be much appreciated as it’s rendered the software useless.

Cheers in advance!

EDIT: it seems to have finally sorted itself.

In the mean time have u tried to download ps4 version to see if that is playable,

1 Like

I’ve got it installed on my PS4s but I had to dash out so didn’t have a chance to try it but that’s the first thing I’ll do when I get in.

Is it Friday the 13th today? :sweat:

@Taf420 am home now and tried it and exactly the same thing happens on the PS4 version of the game.

It looks to be something to do with the Quest Pass Information (under the “King’s Birthday” section at the right of the Tavern home screen) not displaying correctly.

I’m glad I got my dailys out of the way before it happened but won’t be happy if I lose out over the weekend continuing into next week. :face_with_diagonal_mouth: