Update problems

Please someone to help me.I have been playing for a month, I play on bluestacks latest version, I had no problems up to version 0.35.1, automatic update did not work.I’m trying to play today, but after redirecting to the google store to update,I get the message item not found, what am I doing wrong ??

Same here. I’m being told I can’t get into the game until I update, but there’s no update to be found on Google Play.

Same here and when I try to update it through manage apps & devices it doesn’t list it as having an update.

contacted google play service no help from them until it officially released

sri, 21. srp 2021. u 10:05 Queinty via Puzzle Quest 3 <puzzlequest3@discoursemail.com> napisao je:

only hope puzzle quest 3 crew

sri, 21. srp 2021. u 15:30 Vedran Bogdanovic <vedrandrvet@gmail.com> napisao je:

I hope one of the developers will see this and help solve the problem,or give 
or provide an update download address

sri, 21. srp 2021. u 15:32 Vedran Bogdanovic <vedrandrvet@gmail.com> napisao je:

Hey all,

This thread has been raised with the development team.

We’re sorry that you’re all having this issue. Our development team is currently looking into what’s happening so we can get this fixed. They’re just needing a few questions answered to help narrow down the issue.

Could you please answer the following:

  • What country are you from?

  • What Android device are you playing on?

  • What Android Version is the device updated to?

  • How long they’ve been playing Puzzle Quest 3 for?

OminousGMan - Support Team Human

1 Like

Similar problem here, but on iPhone (8 Plus)…
Opening screen says go update, click confirm, it takes me to the app store with nothing found.
Tried deleting and reinstalling from testflight, nothing changed.

Croatia,huawei 9 lite mini android 7 or on pc windows 10 bluestacks latest version,playing for about 2 months level 50 sith 5 characters,citadel 53

čet, 22. srp 2021. u 02:48 Jay Longfellow via Puzzle Quest 3 <puzzlequest3@discoursemail.com> napisao je:

i hope that you see png

čet, 22. srp 2021. u 05:30 Vedran Bogdanovic <vedrandrvet@gmail.com> napisao je:

Hey everyone, we are still looking into this. If you have linked your account you can access the update by uninstalling and reinstalling the game. We have tried this and have found it to be an effective work around. However, if you haven’t linked your account yet you will need to contact our support so they can help you with this issue after you’ve reinstalled. You can find them here.

1 Like

Salty thx for answering,tried to uninstall and reinstall,it didnt work for me,pls help

Please contact our support so we can help you further. I’m sorry the workaround didn’t help.

for everyone with same kind of problem,uptodown realeased update 0.36 and it works