[Fixed] PHOBIA_TYPE prevents playing past seasons

I’m replaying through Season 1.3, Chapter II, Part 5. I’ve hit an issue under the Chapter section which displays a box showing:

You will confront an ENEMY_TYPE in your next battle.
PHOBIA_TYPE settings can be changed at any time in the settings menu.
Do you wish to view these settings now?
[YES] [NO]

Clicking on the buttons does nothing, and all other buttons are disabled on that chapter menu. I’ve set Arachnophobia Mode in the settings to DISABLED and ENABLED, but it doesn’t change anything.


Same issue here on Season 1.1 Khazdhuli.

also having problem playing Season 1.1 storyline. however can play battles. Do the techs see these comments?

@Jeto and Team,

1.3 - Hard chapter 1 part 7

1.4 - Hard Chapter 1 Part 10

Can’t reset, can’t click Yes or No. Totally stuck with these seasons effectively disabled until you fix it.

1.1 Hard Charpter 1 Part 7

There is no more season in the archive that I can play. They are all blocked by the [PHOBIA_TYPE] window. I have screenshots but somehow I’m not allowed to upload them. I guess the new season will be blocked as soon as it starts.

Same problem, same wait for relief.

And to be clear, the spider is waaaaay less scary than that owlbear abomination. That thing haunts me still.

I am also having the same issue and it is now also on the new season that just came out so I can do no archives or the new season and I see no response from any of the devd

1 Like

Almost exactly the same as the OP. I’m playing on PS5 - season 1.3>chapter II>Part 6.

The “NO” button under the [PHOBIA _TYPE] doesn’t do anything and when I click on “YES” the application crashes with an error report.

Thought this will be fixed by upgrade 2.1.
But season 1.1 and 1.4 are still blocked and no chance to play!
Devs, why don’t you just remove this selection feature? Temporary solution is better than waiting, waiting, …

Having the same issue.

@Kafka , how hard is it to just turn this off?

6+ days and many people are completely locked out of all archives AND the current season.

I admit, I haven’t tried to reproduce the issue with the archives, but I encountered the pop-up when playing a regular dungeon. It happened once, I was able to go to the setting and then get back to the dungeon.

I finished the whole chapter 1 of the new season without any issues. The setting is turned off for me.

Out of curiosity - is the setting turned on for all of you? Have you tried turning it off, and have you encountered the popup in regular story dungeon?

1 Like

I can confirm what Heno3 has explained. I also encountered the phobia message in a regular dungeon and turned it off. When doing the season 2.1. story I got no issue at all. Therefore, it seems the issue arises when getting the phobia message first time in one of the seasons.

Just in case, has anyone with the issue tried doing a regular dungeon with spiders in it (dragonrest temple, for example)?

1 Like

I am now totally locked out of all archives.

I have tried opening on another device. No change.
I tried opening in Steam. No change.
I have changed the phobia settings multiple times. No change.

I really think you guys need to escalate this issue. You have console players coming to the forums for the first time reporting this issue. This is the kind of bug that makes people uninstall the game.

In the dungeon, the phobia query appears without error. You can click yes or no and make the settings.
In the archive, the parameter that selects the spider as the graphic to replace seems to have a typo. Therefore you can see the name of the variables PHOBIA_TYPE and ENEMY_TYPE.

Thank you for sharing these screenshots and examples everyone!

I have added them to my previous report of this issue.

Puzzle Quest 3_2023-06-21-19-42-18|690x326

The Phobia Settings warning pop-up isn’t responding. This doesn’t allow the player to continue with story.
As showen in image. Stuck with no way to contune playing.
All other interactive buttons work. I.E battle dungeon loot, skermish loot.
Have followed all suggested ‘Bug fixes’ clearìng cache, etc. Restored Game from server back up Acc log.
Can play regular story line no issues.

Systems Moble Game Android Samsung Galaxy Series.

1 Like

I am having the same problem. Deleted game and downloaded again and still does not work. Anyone know if it is being worked on?

Just moving some duplicate threads into this existing report.